Build Errors

Questions on using RText should go here.

Moderator: robert

Build Errors

Postby Simmonsd » Tue Oct 01, 2013 5:30 pm

I've been trying to build RText from source, and have been experiencing build errors. I've tried following the instructions here as closely as possible, to no avail.

Basically, I've unpacked the source, and tried running ant from both the RText subdirectory and the Common subdirectory. In both cases it gets to the following step

Code: Select all
[javac] Compiling 6 source files to /Users/maegereg/Desktop/rtext_2.0.7_Source 2/Common/ant-classes


and then throws this error:

Code: Select all
/Users/maegereg/Desktop/rtext_2.0.7_Source 2/RText/build.xml:76: The following error occurred while executing this line:
/Users/maegereg/Desktop/rtext_2.0.7_Source 2/Common/build.xml:58: Error running ${javac.16} compiler


I'm working on Mac OS 10.7.5 with JDK 1.7.0_40 installed. I've tried updating the build.xml files to point to javac.17, with no success either. Has the build process changed? Is there something I'm missing?
Simmonsd
 
Posts: 4
Joined: Mon Sep 30, 2013 4:15 am

Re: Build Errors

Postby robert » Wed Oct 02, 2013 1:35 pm

Yes, the build process has changed a little bit. Besides build.xml, you'll want to edit build.properties in the same directory, to point to your desired Java 6+ compiler.

RText is a little silly, and builds with two different compilers. The official release builds most class files with Java 1.4, and some class files (usually having to do with Substance) with Java 6. When building on your own, you can use the same compiler for both (e.g. JDK7) if you want. The whole "two compilers" thing is simply done to keep RText usable with Java 1.4.
User avatar
robert
 
Posts: 797
Joined: Sat May 10, 2008 5:16 pm


Return to Help

Who is online

Users browsing this forum: No registered users and 1 guest

cron