Resource Bundle Error

Post a reply

Smilies
:D :) ;) :( :o :shock: :? 8-) :lol: :x :P :oops: :cry: :evil: :twisted: :roll: :!: :?: :idea: :arrow: :| :mrgreen: :geek: :ugeek:
BBCode is ON
[img] is ON
[flash] is OFF
[url] is ON
Smilies are ON
Topic review
   

Expand view Topic review: Resource Bundle Error

Re: Resource Bundle Error

Post by robert » Thu May 24, 2012 11:21 am

Well, unfortunately I'm not sure how to proceed debugging. This example I mentioned previously should definitely work out of the box. I would suggest running it on the command line, outside of Eclipse or any IDE. Once that's verified as working, create a clean workspace and create a new project, and try to run the example in that. Then import your "real" project into that workspace and continue on. My only guess is that it's some sort of workspace or project setting.

Re: Resource Bundle Error

Post by seiyria » Wed May 23, 2012 10:33 pm

robert wrote:What are the contents of your rsyntaxtextarea.jar file? Are there classes in it? Copy and paste the contents.


http://pastebin.com/umkf6nTA

(don't mind the weird characters; those are just a listing of the tree /f command)
Okay, so I apparently was blind before, there ARE, in fact, .properties files. However, the example still doesn't work, even using this jar. I'm very sorry for the confusion; I didn't look hard enough.

Re: Resource Bundle Error

Post by robert » Wed May 23, 2012 9:16 pm

What are the contents of your rsyntaxtextarea.jar file? Are there classes in it? Copy and paste the contents.

Re: Resource Bundle Error

Post by seiyria » Wed May 23, 2012 3:04 pm

robert wrote:I just verified that the binary zip on SourceForge is correct. Please make sure you're downloading a binary package, such as RSyntaxTextArea_2.0.3.zip, unzipping it, and using the rsyntaxtextarea.jar found inside.


This is exactly what I did -- there are still no .properties files in the jar. Also, I redownloaded it just to be sure, and it definitely doesn't work for me.

Re: Resource Bundle Error

Post by robert » Wed May 23, 2012 12:44 pm

I just verified that the binary zip on SourceForge is correct. Please make sure you're downloading a binary package, such as RSyntaxTextArea_2.0.3.zip, unzipping it, and using the rsyntaxtextarea.jar found inside.

Re: Resource Bundle Error

Post by seiyria » Wed May 23, 2012 3:00 am

robert wrote:Yes, that's definitely the problem. There should be properties files in the jar. I assume you're either getting the jar file from SourceForge, or building it yourself from the source?


I was getting the jar from sourceforge, yeah.

Re: Resource Bundle Error

Post by robert » Tue May 22, 2012 2:48 am

Yes, that's definitely the problem. There should be properties files in the jar. I assume you're either getting the jar file from SourceForge, or building it yourself from the source?

Re: Resource Bundle Error

Post by seiyria » Mon May 21, 2012 3:24 am

robert wrote:Hmm, well I'm not sure how to proceed. If the jar is there, and you can see the *.properties files in it, you should not get that error. The only thing I can think of is a heavy-handed approach - you could send me a zipped up version of your project, along with the command line that does not work. Then I'll have your exact environment to look at.

There's probably a better way to debug this, but my brain is fried at the moment.



My apologies for not being on top of testing this. I was just looking back over this, because I'd taken a break from my project for the last 5 months (wow, time flies). Would not being able to see a .properties file anywhere in the jar be a problem? I don't think I can see any. I'm using 2.0.3 now, as well.

Re: Resource Bundle Error

Post by seiyria » Mon Jan 30, 2012 9:12 pm

It's really nontrivial to get it running via command line (mostly because of SWT, unfortunately), and even setting it up in eclipse takes a bit of work (well, you have to make your own library with a few jars in it). I can still send you the zip and instructions, but I feel like it'd be more work than it's worth at that point.

I have just now tried to use the source and simultaneously linking the i18n folder as well... no dice.

I really do appreciate you being as helpful as you are, though. Thanks for that!

Re: Resource Bundle Error

Post by robert » Mon Jan 30, 2012 2:15 pm

Hmm, well I'm not sure how to proceed. If the jar is there, and you can see the *.properties files in it, you should not get that error. The only thing I can think of is a heavy-handed approach - you could send me a zipped up version of your project, along with the command line that does not work. Then I'll have your exact environment to look at.

There's probably a better way to debug this, but my brain is fried at the moment.

Top